ArcGIS Service Pack 4 Is Out

Yes, that’s right. Another one.

ESRI has released service pack #4 for it’s core suite of products - ArcGIS, ArcIMS, ArcSDE, et. al.

The release notes say:

ArcGIS 9.2 SP4 contains critical fixes and new functionality. It is recommended that all users install this service pack.

It also says for SDE:

It is important to keep all versions of ArcGIS products installed on the same machine in sync to avoid any software conflicts.

and

NOTE (ArcIMS and ArcGIS Desktop users): If you use ArcIMS 9.2 or ArcGIS Desktop 9.2, you must also install ArcIMS 9.2 Service Pack 4 or ArcGIS 9.2 Service Pack 4 . For example, if you use ArcIMS 9.2 and ArcSDE 9.2, install both ArcIMS 9.2 Service Pack 4 and ArcSDE 9.2 Service Pack 4. Since ArcIMS 9.2, ArcSDE 9.2 and the ArcGIS 9.2 products share common DLLs, it is important to keep the software release versions in sync to avoid any software conflicts.
If you turn your monitor on-edge and look at the release notes, it says:

Yes, we know the second thing makes it almost impossible to do the first thing if you have more than one group of GIS users in your organization. Did we mention your annual maintenance is due?

Sigh.

Powered by ScribeFire.